Description:

Constructs a Brep definition of a cylinder.

Syntax:
public static Brep CreateFromCylinder(
Cylinder cylinder,
bool capBottom,
bool capTop
)
Parameters:
  • cylinder
  • Type: Cylinder
  • cylinder.IsFinite() must be true.
  • capBottom
  • Type: bool
  • if True end at cylinder.m_height[0] should be capped.
  • capTop
  • Type: bool
  • if True end at cylinder.m_height[1] should be capped.
Returns:
Type: Brep
A Brep representation of the cylinder with a single face for the cylinder, an edge along the cylinder seam, and vertices at the bottom and top ends of this seam edge. The optional bottom/top caps are single faces with one circular edge starting and ending at the bottom/top vertex.
Available since:
5.0

/
/
/
CreateFromCylinder

CreateFromCylinder method

Class:  Rhino.Geometry.Brep

Nothing found