Description:
Constructs one or more Breps by lofting through a set of curves, optionally matching start and end tangents of surfaces when first and/or last loft curves are surface edges
Parameters:
- curves
- Type: IEnumerable<Curve>
- The curves to loft through. This function will not perform any curve sorting. You must pass in curves in the order you want them lofted. This function will not adjust the directions of open curves. Use Curve.DoDirectionsMatch and Curve.Reverse to adjust the directions of open curves. This function will not adjust the seams of closed curves. Use Curve.ChangeClosedCurveSeam to adjust the seam of closed curves.
- start
- Type: Point3d
- Optional starting point of loft. Use Point3d.Unset if you do not want to include a start point. "start" and "StartTangent" cannot both be true.
- end
- Type: Point3d
- Optional ending point of loft. Use Point3d.Unset if you do not want to include an end point. "end and "EndTangent" cannot both be true.
- StartTangent
- Type: bool
- If StartTangent is True and the first loft curve is a surface edge, the loft will match the tangent of the surface behind that edge.
- EndTangent
- Type: bool
- If EndTangent is True and the first loft curve is a surface edge, the loft will match the tangent of the surface behind that edge.
- StartTrim
- Type: BrepTrim
- BrepTrim from the surface edge where start tangent is to be matched
- EndTrim
- Type: BrepTrim
- BrepTrim from the surface edge where end tangent is to be matched
- loftType
- Type: LoftType
- type of loft to perform.
- closed
- Type: bool
- True if the last curve in this loft should be connected back to the first one.
Returns:
Type: Brep[]
Constructs a closed surface, continuing the surface past the last curve around to the first curve. Available when you have selected three shape curves.
Available since:
7.0
Description:
Constructs one or more Breps by lofting through a set of curves.
Parameters:
- curves
- Type: IEnumerable<Curve>
- The curves to loft through. This function will not perform any curve sorting. You must pass in curves in the order you want them lofted. This function will not adjust the directions of open curves. Use Curve.DoDirectionsMatch and Curve.Reverse to adjust the directions of open curves. This function will not adjust the seams of closed curves. Use Curve.ChangeClosedCurveSeam to adjust the seam of closed curves.
- start
- Type: Point3d
- Optional starting point of loft. Use Point3d.Unset if you do not want to include a start point.
- end
- Type: Point3d
- Optional ending point of loft. Use Point3d.Unset if you do not want to include an end point.
- loftType
- Type: LoftType
- type of loft to perform.
- closed
- Type: bool
- True if the last curve in this loft should be connected back to the first one.
Returns:
Type: Brep[]
Constructs a closed surface, continuing the surface past the last curve around to the first curve. Available when you have selected three shape curves.
Available since:
5.0