Description:
Constructs one or more Breps by lofting through a set of curves. Input for the loft is simplified by refitting to a specified tolerance.
Parameters:
- curves
- Type: IEnumerable<Curve>
- The curves to loft through. This function will not perform any curve sorting. You must pass in curves in the order you want them lofted. This function will not adjust the directions of open curves. Use Curve.DoDirectionsMatch and Curve.Reverse to adjust the directions of open curves. This function will not adjust the seams of closed curves. Use Curve.ChangeClosedCurveSeam to adjust the seam of closed curves.
- start
- Type: Point3d
- Optional starting point of loft. Use Point3d.Unset if you do not want to include a start point.
- end
- Type: Point3d
- Optional ending point of lost. Use Point3d.Unset if you do not want to include an end point.
- loftType
- Type: LoftType
- type of loft to perform.
- closed
- Type: bool
- True if the last curve in this loft should be connected back to the first one.
- refitTolerance
- Type: double
- A distance to use in refitting, or 0 if you want to turn this parameter off.
Returns:
Type: Brep[]
Constructs a closed surface, continuing the surface past the last curve around to the first curve. Available when you have selected three shape curves.
Available since:
5.0