Description:

Constructs a brep form of a surface of revolution.

Syntax:
public static Brep CreateFromRevSurface(
RevSurface surface,
bool capStart,
bool capEnd
)
Parameters:
  • capStart
  • Type: bool
  • if true, the start of the revolute is not on the axis of revolution, and the surface of revolution is closed, then a circular cap will be added to close of the hole at the start of the revolute.
  • capEnd
  • Type: bool
  • if true, the end of the revolute is not on the axis of revolution, and the surface of revolution is closed, then a circular cap will be added to close of the hole at the end of the revolute.
Returns:
Type: Brep
A Brep if successful, None on error.
Available since:
5.0

/
/
/
CreateFromRevSurface

CreateFromRevSurface method

Class:  Rhino.Geometry.Brep

Nothing found