Description:

Sweep1 function that fits a surface through a profile curve that define the surface cross-sections and one curve that defines a surface edge.

Syntax:
public static Brep[] CreateFromSweep(
Curve rail,
Curve shape,
bool closed,
double tolerance
)
Parameters:
  • rail
  • Type: Curve
  • Rail to sweep shapes along
  • shape
  • Type: Curve
  • Shape curve
  • closed
  • Type: bool
  • Only matters if shape is closed
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails
Returns:
Type: Brep[]
Array of Brep sweep results
Available since:
5.0

Description:

Sweep1 function that fits a surface through profile curves that define the surface cross-sections and one curve that defines a surface edge.

Syntax:
public static Brep[] CreateFromSweep(
Curve rail,
IEnumerable<Curve> shapes,
bool closed,
double tolerance
)
Parameters:
  • rail
  • Type: Curve
  • Rail to sweep shapes along
  • shapes
  • Type: IEnumerable<Curve>
  • Shape curves
  • closed
  • Type: bool
  • Only matters if shapes are closed
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails
Returns:
Type: Brep[]
Array of Brep sweep results
Available since:
5.0

Description:

Sweep1 function that fits a surface through a series of profile curves that define the surface cross-sections and one curve that defines a surface edge.

Syntax:
public static Brep[] CreateFromSweep(
Curve rail,
IEnumerable<Curve> shapes,
Point3d startPoint,
Point3d endPoint,
SweepFrame frameType,
Vector3d roadlikeNormal,
bool closed,
SweepBlend blendType,
SweepMiter miterType,
double tolerance,
SweepRebuild rebuildType,
int rebuildPointCount,
double refitTolerance
)
Parameters:
  • rail
  • Type: Curve
  • Rail to sweep shapes along.
  • shapes
  • Type: IEnumerable<Curve>
  • Shape curves.
  • startPoint
  • Type: Point3d
  • Optional starting point of sweep. Use Point3d.Unset if you do not want to include a start point.
  • endPoint
  • Type: Point3d
  • Optional ending point of sweep. Use Point3d.Unset if you do not want to include an end point.
  • roadlikeNormal
  • Type: Vector3d
  • The roadlike normal directoion. Use Vector3d.Unset if the frame type is not set to roadlike.
  • closed
  • Type: bool
  • Only matters if shapes are closed.
  • rebuildPointCount
  • Type: int
  • If rebuild == SweepRebuild.Rebuild, the number of points. Otherwise specify 0.
  • refitTolerance
  • Type: double
  • If rebuild == SweepRebuild.Refit, the refit tolerance. Otherwise, specify 0.0
Returns:
Type: Brep[]
Array of Brep sweep results.
Available since:
7.0

Description:

General 2 rail sweep. If you are not producing the sweep results that you are after, then use the SweepTwoRail class with options to generate the swept geometry.

Syntax:
public static Brep[] CreateFromSweep(
Curve rail1,
Curve rail2,
Curve shape,
bool closed,
double tolerance
)
Parameters:
  • rail1
  • Type: Curve
  • Rail to sweep shapes along
  • rail2
  • Type: Curve
  • Rail to sweep shapes along
  • shape
  • Type: Curve
  • Shape curve
  • closed
  • Type: bool
  • Only matters if shape is closed
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails
Returns:
Type: Brep[]
Array of Brep sweep results
Available since:
5.0

Description:

General 2 rail sweep. If you are not producing the sweep results that you are after, then use the SweepTwoRail class with options to generate the swept geometry.

Syntax:
public static Brep[] CreateFromSweep(
Curve rail1,
Curve rail2,
IEnumerable<Curve> shapes,
bool closed,
double tolerance
)
Parameters:
  • rail1
  • Type: Curve
  • Rail to sweep shapes along
  • rail2
  • Type: Curve
  • Rail to sweep shapes along
  • shapes
  • Type: IEnumerable<Curve>
  • Shape curves
  • closed
  • Type: bool
  • Only matters if shapes are closed
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails
Returns:
Type: Brep[]
Array of Brep sweep results
Available since:
5.0

Description:

Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines the surface edges.

Syntax:
public static Brep[] CreateFromSweep(
Curve rail1,
Curve rail2,
IEnumerable<Curve> shapes,
Point3d start,
Point3d end,
bool closed,
double tolerance,
SweepRebuild rebuild,
int rebuildPointCount,
double refitTolerance,
bool preserveHeight,
bool autoAdjust
)
Parameters:
  • rail1
  • Type: Curve
  • Rail to sweep shapes along
  • rail2
  • Type: Curve
  • Rail to sweep shapes along
  • shapes
  • Type: IEnumerable<Curve>
  • Shape curves
  • start
  • Type: Point3d
  • Optional starting point of sweep. Use Point3d.Unset if you do not want to include a start point.
  • end
  • Type: Point3d
  • Optional ending point of sweep. Use Point3d.Unset if you do not want to include an end point.
  • closed
  • Type: bool
  • Only matters if shapes are closed.
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails.
  • rebuildPointCount
  • Type: int
  • If rebuild == SweepRebuild.Rebuild, the number of points. Otherwise specify 0.
  • refitTolerance
  • Type: double
  • If rebuild == SweepRebuild.Refit, the refit tolerance. Otherwise, specify 0.0
  • preserveHeight
  • Type: bool
  • Removes the association between the height scaling from the width scaling
  • autoAdjust
  • Type: bool
  • Set to True to have shape curves adjusted, sorted, and matched automatically. This will produce results comparable to Rhino's Sweep2 command. Set to False to not have shape curves adjusted, sorted, and matched automatically.
Returns:
Type: Brep[]
Array of Brep sweep results
Available since:
7.19

Description:

Sweep2 function that fits a surface through profile curves that define the surface cross-sections and two curves that defines the surface edges.

Syntax:
public static Brep[] CreateFromSweep(
Curve rail1,
Curve rail2,
IEnumerable<Curve> shapes,
Point3d start,
Point3d end,
bool closed,
double tolerance,
SweepRebuild rebuild,
int rebuildPointCount,
double refitTolerance,
bool preserveHeight
)
Parameters:
  • rail1
  • Type: Curve
  • Rail to sweep shapes along
  • rail2
  • Type: Curve
  • Rail to sweep shapes along
  • shapes
  • Type: IEnumerable<Curve>
  • Shape curves
  • start
  • Type: Point3d
  • Optional starting point of sweep. Use Point3d.Unset if you do not want to include a start point.
  • end
  • Type: Point3d
  • Optional ending point of sweep. Use Point3d.Unset if you do not want to include an end point.
  • closed
  • Type: bool
  • Only matters if shapes are closed.
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails.
  • rebuildPointCount
  • Type: int
  • If rebuild == SweepRebuild.Rebuild, the number of points. Otherwise specify 0.
  • refitTolerance
  • Type: double
  • If rebuild == SweepRebuild.Refit, the refit tolerance. Otherwise, specify 0.0
  • preserveHeight
  • Type: bool
  • Removes the association between the height scaling from the width scaling
Returns:
Type: Brep[]
Array of Brep sweep results
Available since:
6.16

/
/
/
CreateFromSweep

CreateFromSweep method

Class:  Rhino.Geometry.Brep

Nothing found