Description:

Makes a 2 rail sweep. Like CreateFromSweep but the result is split where parameterization along a rail changes abruptly.

Syntax:
public static Brep[] CreateFromSweepInParts(
Curve rail1,
Curve rail2,
IEnumerable<Curve> shapes,
IEnumerable<Point2d> rail_params,
bool closed,
double tolerance
)
Parameters:
  • rail1
  • Type: Curve
  • Rail to sweep shapes along
  • rail2
  • Type: Curve
  • Rail to sweep shapes along
  • shapes
  • Type: IEnumerable<Curve>
  • Shape curves
  • rail_params
  • Type: IEnumerable<Point2d>
  • Shape parameters
  • closed
  • Type: bool
  • Only matters if shapes are closed
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails
Returns:
Type: Brep[]
Array of Brep sweep results
Available since:
6.0

/
/
/
CreateFromSweepInParts

CreateFromSweepInParts method

Class:  Rhino.Geometry.Brep

Nothing found