Description:

Sweep1 function that fits a surface through a profile curve that define the surface cross-sections and one curve that defines a surface edge. The Segmented version breaks the rail at curvature kinks and sweeps each piece separately, then put the results together into a Brep.

Syntax:
public static Brep[] CreateFromSweepSegmented(
Curve rail,
Curve shape,
bool closed,
double tolerance
)
Parameters:
  • rail
  • Type: Curve
  • Rail to sweep shapes along
  • shape
  • Type: Curve
  • Shape curve
  • closed
  • Type: bool
  • Only matters if shape is closed
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails
Returns:
Type: Brep[]
Array of Brep sweep results
Available since:
6.14

Description:

Sweep1 function that fits a surface through a series of profile curves that define the surface cross-sections and one curve that defines a surface edge. The Segmented version breaks the rail at curvature kinks and sweeps each piece separately, then put the results together into a Brep.

Syntax:
public static Brep[] CreateFromSweepSegmented(
Curve rail,
IEnumerable<Curve> shapes,
bool closed,
double tolerance
)
Parameters:
  • rail
  • Type: Curve
  • Rail to sweep shapes along.
  • shapes
  • Type: IEnumerable<Curve>
  • Shape curves.
  • closed
  • Type: bool
  • Only matters if shapes are closed.
  • tolerance
  • Type: double
  • Tolerance for fitting surface and rails.
Returns:
Type: Brep[]
Array of Brep sweep results.
Available since:
6.14

Description:

Sweep1 function that fits a surface through a series of profile curves that define the surface cross-sections and one curve that defines a surface edge. The Segmented version breaks the rail at curvature kinks and sweeps each piece separately, then put the results together into a Brep.

Syntax:
public static Brep[] CreateFromSweepSegmented(
Curve rail,
IEnumerable<Curve> shapes,
Point3d startPoint,
Point3d endPoint,
SweepFrame frameType,
Vector3d roadlikeNormal,
bool closed,
SweepBlend blendType,
SweepMiter miterType,
double tolerance,
SweepRebuild rebuildType,
int rebuildPointCount,
double refitTolerance
)
Parameters:
  • rail
  • Type: Curve
  • Rail to sweep shapes along.
  • shapes
  • Type: IEnumerable<Curve>
  • Shape curves.
  • startPoint
  • Type: Point3d
  • Optional starting point of sweep. Use Point3d.Unset if you do not want to include a start point.
  • endPoint
  • Type: Point3d
  • Optional ending point of sweep. Use Point3d.Unset if you do not want to include an end point.
  • roadlikeNormal
  • Type: Vector3d
  • The roadlike normal directoion. Use Vector3d.Unset if the frame type is not set to roadlike.
  • closed
  • Type: bool
  • Only matters if shapes are closed.
  • rebuildPointCount
  • Type: int
  • If rebuild == SweepRebuild.Rebuild, the number of points. Otherwise specify 0.
  • refitTolerance
  • Type: double
  • If rebuild == SweepRebuild.Refit, the refit tolerance. Otherwise, specify 0.0
Returns:
Type: Brep[]
Array of Brep sweep results.
Available since:
7.0

/
/
/
CreateFromSweepSegmented

CreateFromSweepSegmented method

Class:  Rhino.Geometry.Brep

Nothing found