Description:

Extrude a curve to a taper making a brep (potentially more than 1)

Syntax:
public static Brep[] CreateFromTaperedExtrude(
Curve curveToExtrude,
double distance,
Vector3d direction,
Point3d basePoint,
double draftAngleRadians,
ExtrudeCornerType cornerType,
double tolerance,
double angleToleranceRadians
)
Parameters:
  • curveToExtrude
  • Type: Curve
  • the curve to extrude
  • distance
  • Type: double
  • the distance to extrude
  • direction
  • Type: Vector3d
  • the direction of the extrusion
  • basePoint
  • Type: Point3d
  • the base point of the extrusion
  • draftAngleRadians
  • Type: double
  • angle of the extrusion
  • tolerance
  • Type: double
  • tolerance to use for the extrusion
  • angleToleranceRadians
  • Type: double
  • angle tolerance to use for the extrusion
Returns:
Type: Brep[]
array of breps on success
Available since:
6.0

Description:

Extrude a curve to a taper making a brep (potentially more than 1)

Syntax:
public static Brep[] CreateFromTaperedExtrude(
Curve curveToExtrude,
double distance,
Vector3d direction,
Point3d basePoint,
double draftAngleRadians,
ExtrudeCornerType cornerType
)
deprecated in 6.0
obsolete: Use version that takes tolerance as input
Parameters:
  • curveToExtrude
  • Type: Curve
  • the curve to extrude
  • distance
  • Type: double
  • the distance to extrude
  • direction
  • Type: Vector3d
  • the direction of the extrusion
  • basePoint
  • Type: Point3d
  • the base point of the extrusion
  • draftAngleRadians
  • Type: double
  • angle of the extrusion
Returns:
Type: Brep[]
array of breps on success
Remarks:
tolerances used are based on the active doc tolerance
Available since:
5.1

/
/
/
CreateFromTaperedExtrude

CreateFromTaperedExtrude method

Class:  Rhino.Geometry.Brep

Nothing found