Description:

Creates one or more Breps by extruding a curve a distance along an axis with draft angle.

Syntax:
public static Brep[] CreateFromTaperedExtrudeWithRef(
Curve curve,
Vector3d direction,
double distance,
double draftAngle,
Plane plane,
double tolerance
)
Parameters:
  • curve
  • Type: Curve
  • The curve to extrude.
  • direction
  • Type: Vector3d
  • The extrusion direction.
  • distance
  • Type: double
  • The extrusion distance.
  • draftAngle
  • Type: double
  • The extrusion draft angle in radians.
  • plane
  • Type: Plane
  • The end of the extrusion will be parallel to this plane, and "distance" from the plane's origin. The plane's origin is generally be a point on the curve. For planar curves, a natural choice for the plane's normal direction will be the normal direction of the curve's plane. In any case, plane.Normal = direction may make sense.
  • tolerance
  • Type: double
  • The intersecting and trimming tolerance.
Returns:
Type: Brep[]
An array of Breps if successful.
Available since:
6.14

/
/
/
CreateFromTaperedExtrudeWithRef

CreateFromTaperedExtrudeWithRef method

Class:  Rhino.Geometry.Brep

Nothing found