Description:
Offsets a Brep.
Parameters:
- brep
- Type: Brep
- The Brep to offset.
- distance
- Type: double
- The distance to offset. This is a signed distance value with respect to face normals and flipped faces.
- solid
- Type: bool
- If true, then the function makes a closed solid from the input and offset surfaces by lofting a ruled surface between all of the matching edges.
- extend
- Type: bool
- If true, then the function maintains the sharp corners when the original surfaces have sharps corner. If False, then the function creates fillets at sharp corners in the original surfaces.
- shrink
- Type: bool
- If true, then the function shrinks the underlying surfaces to their face's outer boundary loop.
- tolerance
- Type: double
- The offset tolerance.
- outBlends
- Type: Brep[]
- The results of the calculation.
- outWalls
- Type: Brep[]
- The results of the calculation.
Returns:
Type: Brep[]
Array of Breps if successful. If the function succeeds in offsetting, a single Brep will be returned. Otherwise, the array will contain the offset surfaces, outBlends will contain the set of blends used to fill in gaps (if extend is false), and outWalls will contain the set of wall surfaces that was supposed to join the offset to the original (if solid is true).
Available since:
7.5
Description:
Offsets a Brep.
Parameters:
- brep
- Type: Brep
- The Brep to offset.
- distance
- Type: double
- The distance to offset. This is a signed distance value with respect to face normals and flipped faces.
- solid
- Type: bool
- If true, then the function makes a closed solid from the input and offset surfaces by lofting a ruled surface between all of the matching edges.
- extend
- Type: bool
- If true, then the function maintains the sharp corners when the original surfaces have sharps corner. If False, then the function creates fillets at sharp corners in the original surfaces.
- tolerance
- Type: double
- The offset tolerance.
- outBlends
- Type: Brep[]
- The results of the calculation.
- outWalls
- Type: Brep[]
- The results of the calculation.
Returns:
Type: Brep[]
Array of Breps if successful. If the function succeeds in offsetting, a single Brep will be returned. Otherwise, the array will contain the offset surfaces, outBlends will contain the set of blends used to fill in gaps (if extend is false), and outWalls will contain the set of wall surfaces that was supposed to join the offset to the original (if solid is true).
Available since:
6.0