Description:

Creates a double-walled pipe.

Syntax:
public static Brep[] CreateThickPipe(
Curve rail,
double radius0,
double radius1,
bool localBlending,
PipeCapMode cap,
bool fitRail,
double absoluteTolerance,
double angleToleranceRadians
)
Parameters:
  • rail
  • Type: Curve
  • The rail, or path, curve.
  • radius0
  • Type: double
  • The first radius of the pipe.
  • radius1
  • Type: double
  • The second radius of the pipe.
  • localBlending
  • Type: bool
  • The shape blending. If True, Local (pipe radius stays constant at the ends and changes more rapidly in the middle) is applied. If False, Global (radius is linearly blended from one end to the other, creating pipes that taper from one radius to the other) is applied.
  • fitRail
  • Type: bool
  • If the curve is a polycurve of lines and arcs, the curve is fit and a single surface is created; otherwise the result is a Brep with joined surfaces created from the polycurve segments.
  • absoluteTolerance
  • Type: double
  • The sweeping and fitting tolerance. When in doubt, use the document's absolute tolerance.
  • angleToleranceRadians
  • Type: double
  • The angle tolerance. When in doubt, use the document's angle tolerance in radians.
Returns:
Type: Brep[]
Array of Breps success.
Available since:
7.0

Description:

Creates a double-walled pipe.

Syntax:
public static Brep[] CreateThickPipe(
Curve rail,
IEnumerable<double> railRadiiParameters,
IEnumerable<double> radii0,
IEnumerable<double> radii1,
bool localBlending,
PipeCapMode cap,
bool fitRail,
double absoluteTolerance,
double angleToleranceRadians
)
Parameters:
  • rail
  • Type: Curve
  • The rail, or path, curve.
  • railRadiiParameters
  • Type: IEnumerable<double>
  • One or more normalized curve parameters where changes in radius occur. Important: curve parameters must be normalized - ranging between 0.0 and 1.0. Use Interval.NormalizedParameterAt to calculate these.
  • radii0
  • Type: IEnumerable<double>
  • One or more radii for the first wall - one at each normalized curve parameter in railRadiiParameters.
  • radii1
  • Type: IEnumerable<double>
  • One or more radii for the second wall - one at each normalized curve parameter in railRadiiParameters.
  • localBlending
  • Type: bool
  • The shape blending. If True, Local (pipe radius stays constant at the ends and changes more rapidly in the middle) is applied. If False, Global (radius is linearly blended from one end to the other, creating pipes that taper from one radius to the other) is applied.
  • fitRail
  • Type: bool
  • If the curve is a polycurve of lines and arcs, the curve is fit and a single surface is created; otherwise the result is a Brep with joined surfaces created from the polycurve segments.
  • absoluteTolerance
  • Type: double
  • The sweeping and fitting tolerance. When in doubt, use the document's absolute tolerance.
  • angleToleranceRadians
  • Type: double
  • The angle tolerance. When in doubt, use the document's angle tolerance in radians.
Returns:
Type: Brep[]
Array of Breps success.
Available since:
7.0

/
/
/
CreateThickPipe

CreateThickPipe method

Class:  Rhino.Geometry.Brep

Nothing found