menu
RhinoCommon API
search
search
V8
arrow_drop_down
new_releases
wb_sunny
RhinoCommon documentation has a new look. The old site can still be found
here
.
Close
Description:
Create a Brep trimmed plane.
Syntax:
public static
Brep
CreateTrimmedPlane(
Plane
plane
,
Curve
curve
)
Parameters:
plane
Type:
Plane
Plane that will be trimmed.
curve
Type:
Curve
A simple (no self intersections) closed curve that defines the outer boundary of the trimmed plane.
Returns:
Type:
Brep
Resulting brep or None on failure.
Available since:
6.0
Description:
Create a Brep trimmed plane.
Syntax:
public static
Brep
CreateTrimmedPlane(
Plane
plane
,
IEnumerable<Curve>
curves
)
Parameters:
plane
Type:
Plane
Plane that will be trimmed.
curves
Type:
IEnumerable<Curve>
A list of curves that form a simple (no self intersections) closed curve that defines the outer boundary of the trimmed plane.
Returns:
Type:
Brep
Resulting brep or None on failure.
Available since:
6.0
home
/
Rhino.Geometry
/
Brep
/
CreateTrimmedPlane
CreateTrimmedPlane method
Class:
Rhino.Geometry.Brep
Nothing found