Description:

Constructs a Brep using the trimming information of a brep face and a surface. Surface must be roughly the same shape and in the same location as the trimming brep face.

Syntax:
public static Brep CreateTrimmedSurface(
BrepFace trimSource,
Surface surfaceSource,
double tolerance
)
Parameters:
  • trimSource
  • Type: BrepFace
  • BrepFace which contains trimmingSource brep.
  • surfaceSource
  • Type: Surface
  • Surface that trims of BrepFace will be applied to.
Returns:
Type: Brep
A brep with the shape of surfaceSource and the trims of trimSource or None on failure.
Available since:
6.0

Description:

Constructs a Brep using the trimming information of a brep face and a surface. Surface must be roughly the same shape and in the same location as the trimming brep face.

Syntax:
public static Brep CreateTrimmedSurface(
BrepFace trimSource,
Surface surfaceSource
)
deprecated in 6.0
obsolete: Use version that takes tolerance as input
Parameters:
  • trimSource
  • Type: BrepFace
  • BrepFace which contains trimmingSource brep.
  • surfaceSource
  • Type: Surface
  • Surface that trims of BrepFace will be applied to.
Returns:
Type: Brep
A brep with the shape of surfaceSource and the trims of trimSource or None on failure.
Available since:
5.0

/
/
/
CreateTrimmedSurface

CreateTrimmedSurface method

Class:  Rhino.Geometry.Brep

Nothing found