Description:

Finds a point inside of a solid Brep.

Syntax:
public bool GetPointInside(
double tolerance,
out Point3d point
)
Parameters:
  • tolerance
  • Type: double
  • Used for intersecting rays and is not necessarily related to the distance from the brep to the found point. When in doubt, use the document's model absolute tolerance.
  • point
  • Type: Point3d
  • A point inside the solid Brep.
Returns:
Type: bool
Returns False if the input is not solid and manifold, if the Brep's bounding box is less than 2.0 * tolerance wide, or if no point could be found due to ray shooting or other errors. Otherwise, True is returned.
Available since:
6.19

/
/
/
GetPointInside

GetPointInside method

Class:  Rhino.Geometry.Brep

Nothing found