Description:

If this Brep has two or more components connected by tangent edges, then duplicates of the connected components are returned.

Syntax:
public Brep[] GetTangentConnectedComponents(
double angleTolerance,
bool includeMeshes
)
Parameters:
  • angleTolerance
  • Type: double
  • The angle tolerance, in radians, used to determine tangent edges.
  • includeMeshes
  • Type: bool
  • If true, any cached meshes on this Brep are copied to the returned Breps.
Returns:
Type: Brep[]
An array of tangent edge connected components, or an empty array.
Available since:
8.7

/
/
/
GetTangentConnectedComponents

GetTangentConnectedComponents method

Class:  Rhino.Geometry.Brep

Nothing found