Description:

Individually insets faces of a brep by offsetting the faces outer edges inward and inner edges out then splitting the face with the offset curves.

Syntax:
public Brep InsetFaces(
IEnumerable<int> faceIndices,
double distance,
bool loose,
bool ignoreSeams,
bool creaseCorners,
double tolerance,
double angleTolerance
)
Parameters:
  • faceIndices
  • Type: IEnumerable<int>
  • the indices of the faces to inset
  • distance
  • Type: double
  • The distance to offset along the face
  • loose
  • Type: bool
  • If true, offset by moving edit points otherwise offset within tolerance.
  • ignoreSeams
  • Type: bool
  • If true, the seam edges are not offset and adjacent edges are extended to meet the seam. Otherwise offset normally.
  • creaseCorners
  • Type: bool
  • If true, splitting curves will be made between the creases on edge curves and creases on the inset curves.
  • tolerance
  • Type: double
  • The fitting tolerance for the offset. When in doubt, use the document's absolute tolerance.
  • angleTolerance
  • Type: double
  • The angle tolerance in radians for identifying creases when creasing corners. When in doubt, use the document's angle tolerance.
Returns:
Type: Brep
The brep with inset faces on success. Null on error.
Available since:
8.8

InsetFaces method

Class:  Rhino.Geometry.Brep

Nothing found