Description:

Determines if point is inside a Brep. This question only makes sense when the brep is a closed and manifold. This function does not check for closed or manifold, so result is not valid in those cases. Intersects a line through point with brep, finds the intersection point Q closest to point, and looks at face normal at Q. If the point Q is on an edge or the intersection is not transverse at Q, then another line is used.

Syntax:
public bool IsPointInside(
Point3d point,
double tolerance,
bool strictlyIn
)
Parameters:
  • point
  • Type: Point3d
  • 3d point to test.
  • tolerance
  • Type: double
  • 3d distance tolerance used for intersection and determining strict inclusion. A good default is RhinoMath.SqrtEpsilon.
  • strictlyIn
  • Type: bool
  • if true, point is in if inside brep by at least tolerance. if false, point is in if truly in or within tolerance of boundary.
Returns:
Type: bool
True if point is in, False if not.
Available since:
5.0

/
/
/
IsPointInside

IsPointInside method

Class:  Rhino.Geometry.Brep

Nothing found