Description:

Expert user function that tests the brep to see if its geometry information is valid. The value of brep.IsValidTopology() must be True before brep.IsValidGeometry() can be safely called.

Syntax:
public bool IsValidGeometry(
out string log
)
Parameters:
  • log
  • Type: string
  • If the brep geometry is not valid, then a brief description of the problem in English is assigned to this out parameter. The information is suitable for low-level debugging purposes by programmers and is not intended to be useful as a high level user interface tool. Otherwise, string.Empty .
Returns:
Type: bool
A value that indicates whether the geometry is valid.
Available since:
5.0

/
/
/
IsValidGeometry

IsValidGeometry method

Class:  Rhino.Geometry.Brep

Nothing found