Description:

Expert user function that tests the brep to see if its tolerances and flags are valid. The values of brep.IsValidTopology() and brep.IsValidGeometry() must be True before brep.IsValidTolerancesAndFlags() can be safely called.

Syntax:
public bool IsValidTolerancesAndFlags(
out string log
)
Parameters:
  • log
  • Type: string
  • If the brep tolerance or flags are not valid, then a brief description of the problem in English is assigned to this out parameter. The information is suitable for low-level debugging purposes by programmers and is not intended to be useful as a high level user interface tool. Otherwise, string.Empty .
Returns:
Type: bool
A value that indicates
Available since:
5.0

/
/
/
IsValidTolerancesAndFlags

IsValidTolerancesAndFlags method

Class:  Rhino.Geometry.Brep

Nothing found