Description:

If any edges of this brep overlap edges of otherBrep, merge a copy of otherBrep into this brep joining all edges that overlap within tolerance.

Syntax:
public bool Join(
Brep otherBrep,
double tolerance,
bool compact
)
Parameters:
  • otherBrep
  • Type: Brep
  • Brep to be added to this brep.
  • tolerance
  • Type: double
  • 3d distance tolerance for detecting overlapping edges.
  • compact
  • Type: bool
  • if true, set brep flags and tolerances, remove unused faces and edges.
Returns:
Type: bool
True if any edges were joined.
Remarks:
if no edges overlap, this brep is unchanged. otherBrep is copied if it is merged with this, and otherBrep is always unchanged Use this to join a list of breps in a series. When joining multiple breps in series, compact should be set to false. Call compact on the last Join.
Available since:
5.0

Join method

Class:  Rhino.Geometry.Brep

Nothing found