Description:
Joins the breps in the input array at any overlapping edges to form as few as possible resulting breps. There may be more than one brep in the result array.
Parameters:
- brepsToJoin
- Type: IEnumerable<Brep>
- A list, an array or any enumerable set of breps to join.
- tolerance
- Type: double
- 3d distance tolerance for detecting overlapping edges. When in doubt, use the document's model absolute tolerance.
- angleTolerance
- Type: double
- Angle tolerance, in radians, used for merging edges. When in doubt, use the document's model angle tolerance.
- indexMap
- Type: List<int[]>
- List of integer arrays, one for each joined result, containing all input Brep indices that went into making each result. Note, this can be null.
Returns:
Type: Brep[]
New joined breps on success, None on failure.
Available since:
8.5
Description:
Joins the breps in the input array at any overlapping edges to form as few as possible resulting breps. There may be more than one brep in the result array.
Parameters:
- brepsToJoin
- Type: IEnumerable<Brep>
- A list, an array or any enumerable set of breps to join.
- tolerance
- Type: double
- 3d distance tolerance for detecting overlapping edges. When in doubt, use the document's model absolute tolerance.
- angleTolerance
- Type: double
- Angle tolerance, in radians, used for merging edges. When in doubt, use the document's model angle tolerance.
Returns:
Type: Brep[]
New joined breps on success, None on failure.
Available since:
8.3
Description:
Joins the breps in the input array at any overlapping edges to form as few as possible resulting breps. There may be more than one brep in the result array.