Description:

Joins two naked edges, or edges that are coincident or close together.

Syntax:
public bool JoinEdges(
int edgeIndex0,
int edgeIndex1,
double joinTolerance,
bool compact
)
Parameters:
  • edgeIndex0
  • Type: int
  • The first edge index.
  • edgeIndex1
  • Type: int
  • The second edge index.
  • joinTolerance
  • Type: double
  • The join tolerance.
  • compact
  • Type: bool
  • If joining more than one edge pair and want the edge indices of subsequent pairs to remain valid, set to false. But then call Brep.Compact() on the final result.
Returns:
Type: bool
True if successful, False otherwise.
Available since:
6.0

JoinEdges method

Class:  Rhino.Geometry.Brep

Nothing found