Description:

Merges two surfaces into one surface at untrimmed edges. Both surfaces must be untrimmed and share an edge.

Syntax:
public static Brep MergeSurfaces(
Brep brep0,
Brep brep1,
double tolerance,
double angleToleranceRadians,
Point2d point0,
Point2d point1,
double roundness,
bool smooth
)
Parameters:
  • brep0
  • Type: Brep
  • The first single-face Brep to merge.
  • brep1
  • Type: Brep
  • The second single-face Brep to merge.
  • tolerance
  • Type: double
  • Surface edges must be within this tolerance for the two surfaces to merge.
  • angleToleranceRadians
  • Type: double
  • Edge must be within this angle tolerance in order for contiguous edges to be combined into a single edge.
  • point0
  • Type: Point2d
  • 2D pick point on the first single-face Brep. The value can be unset.
  • point1
  • Type: Point2d
  • 2D pick point on the second single-face Brep. The value can be unset.
  • roundness
  • Type: double
  • Defines the roundness of the merge. Acceptable values are between 0.0 (sharp) and 1.0 (smooth).
  • smooth
  • Type: bool
  • The surface will be smooth. This makes the surface behave better for control point editing, but may alter the shape of both surfaces.
Returns:
Type: Brep
The merged Brep if successful, None if not successful.
Available since:
6.0

Description:

Merges two surfaces into one surface at untrimmed edges. Both surfaces must be untrimmed and share an edge.

Syntax:
public static Brep MergeSurfaces(
Brep brep0,
Brep brep1,
double tolerance,
double angleToleranceRadians
)
Parameters:
  • brep0
  • Type: Brep
  • The first single-face Brep to merge.
  • brep1
  • Type: Brep
  • The second single-face Brep to merge.
  • tolerance
  • Type: double
  • Surface edges must be within this tolerance for the two surfaces to merge.
  • angleToleranceRadians
  • Type: double
  • Edge must be within this angle tolerance in order for contiguous edges to be combined into a single edge.
Returns:
Type: Brep
The merged Brep if successful, None if not successful.
Available since:
6.0

Description:

Merges two surfaces into one surface at untrimmed edges.

Syntax:
public static Brep MergeSurfaces(
Surface surface0,
Surface surface1,
double tolerance,
double angleToleranceRadians
)
Parameters:
  • surface0
  • Type: Surface
  • The first surface to merge.
  • surface1
  • Type: Surface
  • The second surface to merge.
  • tolerance
  • Type: double
  • Surface edges must be within this tolerance for the two surfaces to merge.
  • angleToleranceRadians
  • Type: double
  • Edge must be within this angle tolerance in order for contiguous edges to be combined into a single edge.
Returns:
Type: Brep
The merged surfaces as a Brep if successful, None if not successful.
Available since:
6.0

/
/
/
MergeSurfaces

MergeSurfaces method

Class:  Rhino.Geometry.Brep

Nothing found