Description:

If the brep.Faces[faceIndex] is planar, and all the adjacent faces are planar, this function transforms brep.Faces[faceIndex] with the transform parameter and recomputes the adjacent faces. See the PushPull commands extend mode.

Syntax:
public Brep PushPullExtend(
int faceIndex,
Transform transform,
double tolerance
)
Parameters:
  • faceIndex
  • Type: int
  • The index of the face being transformed
  • tolerance
  • Type: double
  • The tolerance for planarity checks. When in doubt, use the document's absolute tolerance.
Returns:
Type: Brep
The brep with the transformed face on success. Null on error.
Available since:
8.16

/
/
/
PushPullExtend

PushPullExtend method

Class:  Rhino.Geometry.Brep

Nothing found