Description:

Set tolerances and flags in a Brep.

Syntax:
public void SetTolerancesBoxesAndFlags()
Returns:
Type: void
Available since:
6.0

Description:

Set tolerances and flags in a Brep.

Syntax:
public void SetTolerancesBoxesAndFlags(
bool bLazy,
bool bSetVertexTolerances,
bool bSetEdgeTolerances,
bool bSetTrimTolerances,
bool bSetTrimIsoFlags,
bool bSetTrimTypeFlags,
bool bSetLoopTypeFlags,
bool bSetTrimBoxes
)
Parameters:
  • bLazy
  • Type: bool
  • If true, only flags and tolerances that are not set will be calculated.
  • bSetVertexTolerances
  • Type: bool
  • Set True to compute BrepVertex tolerances.
  • bSetEdgeTolerances
  • Type: bool
  • Set True to compute BrepEdge tolerances.
  • bSetTrimTolerances
  • Type: bool
  • Set True to compute BrepTrim tolerances.
  • bSetTrimIsoFlags
  • Type: bool
  • Set True to compute BrepTrim.IsoStatus values.
  • bSetTrimTypeFlags
  • Type: bool
  • Set True to compute BrepTrim.TrimType values.
  • bSetLoopTypeFlags
  • Type: bool
  • Set True to compute BrepLoop.BrepLoopType values.
  • bSetTrimBoxes
  • Type: bool
  • Set True to compute BrepTrim bounding boxes.
Returns:
Type: void
Available since:
6.0

/
/
/
SetTolerancesBoxesAndFlags

SetTolerancesBoxesAndFlags method

Class:  Rhino.Geometry.Brep

Nothing found