Description:

Splits a Brep into pieces using a Brep as a cutter.

Syntax:
public Brep[] Split(
Brep cutter,
double intersectionTolerance,
out bool toleranceWasRaised
)
Parameters:
  • cutter
  • Type: Brep
  • The Brep to use as a cutter.
  • intersectionTolerance
  • Type: double
  • The tolerance with which to compute intersections.
  • toleranceWasRaised
  • Type: bool
  • Set to True if the split failed at intersectionTolerance but succeeded when the tolerance was increased to twice intersectionTolerance.
Returns:
Type: Brep[]
A new array of Breps. This array can be empty.
Available since:
5.0

Description:

Splits a Brep into pieces using a Brep as a cutter.

Syntax:
public Brep[] Split(
Brep cutter,
double intersectionTolerance
)
Parameters:
  • cutter
  • Type: Brep
  • The Brep to use as a cutter.
  • intersectionTolerance
  • Type: double
  • The tolerance with which to compute intersections.
Returns:
Type: Brep[]
A new array of Breps. This array can be empty.
Available since:
5.0

Description:

Splits a Brep into pieces using Breps as cutters.

Syntax:
public Brep[] Split(
IEnumerable<Brep> cutters,
double intersectionTolerance
)
Parameters:
  • cutters
  • Type: IEnumerable<Brep>
  • One or more Breps to use as cutters.
  • intersectionTolerance
  • Type: double
  • The tolerance with which to compute intersections.
Returns:
Type: Brep[]
A new array of Breps. This array can be empty.
Available since:
6.13

Description:

Splits a Brep into pieces using curves, at least partially on the Brep, as cutters.

Syntax:
public Brep[] Split(
IEnumerable<Curve> cutters,
double intersectionTolerance
)
Parameters:
  • cutters
  • Type: IEnumerable<Curve>
  • The splitting curves. Only the portion of the curve on the Brep surface will be used for cutting.
  • intersectionTolerance
  • Type: double
  • The tolerance with which to compute intersections.
Returns:
Type: Brep[]
A new array of Breps. This array can be empty.
Available since:
6.13

Description:

Splits a Brep into pieces using a combination of curves, to be extruded, and Breps as cutters.

Syntax:
public Brep[] Split(
IEnumerable<GeometryBase> cutters,
Vector3d normal,
bool planView,
double intersectionTolerance
)
Parameters:
  • cutters
  • Type: IEnumerable<GeometryBase>
  • The curves, surfaces, faces and Breps to be used as cutters. Any other geometry is ignored.
  • normal
  • Type: Vector3d
  • A construction plane normal, used in deciding how to extrude a curve into a cutter.
  • planView
  • Type: bool
  • Set True if the assume view is a plan, or parallel projection, view.
  • intersectionTolerance
  • Type: double
  • The tolerance with which to compute intersections.
Returns:
Type: Brep[]
A new array of Breps. This array can be empty.
Remarks:
A Curve in cutters is extruded to produce a surface to use as a cutter. The extrusion direction is chosen, as in the Rhino Split command, based on the properties of the active view. In particular the construction plane Normal and whether the active view is a plan view, a parallel projection with construction plane normal as the view direction. If planView is False and the curve is planar then the curve is extruded perpendicular to the curve, otherwise the curve is extruded in the normal direction.
Available since:
6.13

Split method

Class:  Rhino.Geometry.Brep

Nothing found