Description:

Separates, or splits, a disjoint Brep into separate Breps.

Syntax:
public static Brep[] SplitDisjointPieces(
Brep brep,
out List<int[]> indexMap
)
Parameters:
  • brep
  • Type: Brep
  • The disjoint Brep to separate.
  • indexMap
  • Type: List<int[]>
  • List of integer arrays, one for each result, containing all input Brep face indices that went into making each result. Note, this can be null.
Returns:
Type: Brep[]
An array of Brep pieces if successful, otherwise an empty array if the Brep is not disjoint or on error.
Available since:
8.15

Description:

Separates, or splits, a disjoint Brep into separate Breps.

Syntax:
public static Brep[] SplitDisjointPieces(
Brep brep
)
Parameters:
  • brep
  • Type: Brep
  • The disjoint Brep to separate.
Returns:
Type: Brep[]
An array of Brep pieces if successful, otherwise an empty array if the Brep is not disjoint or on error.
Available since:
8.15

/
/
/
SplitDisjointPieces

SplitDisjointPieces method

Class:  Rhino.Geometry.Brep

Nothing found