Description:

Attempts to convert a generic Geometry object into a Brep.

Syntax:
public static Brep TryConvertBrep(
GeometryBase geometry
)
Parameters:
  • geometry
  • Type: GeometryBase
  • Geometry to convert, not all types of GeometryBase can be represented by BReps.
Returns:
Type: Brep
Brep if a brep form could be created or None if this is not possible. If geometry was of type Brep to begin with, the same object is returned, i.e. it is not duplicated.
Available since:
5.0

/
/
/
TryConvertBrep

TryConvertBrep method

Class:  Rhino.Geometry.Brep

Nothing found