Circle struct

Represents a circle in 3D. The values used are a radius and an orthonormal frame of the plane containing the circle, with origin at the center. The circle is parameterized by radians from 0 to 2 Pi given by t -> center + cos(t)*radius*xaxis + sin(t)*radius*yaxis where center, xaxis and yaxis define the orthonormal frame of the circle plane.

>An IsValid circle has positive radius and an IsValid plane defining the frame.

Namespace: Rhino.Geometry
Circle: references

Nothing found