Description:

Create and add a new face to this list. An incomplete face is added. The caller must create and fill in the loops used by the face.

Syntax:
public BrepFace Add(
int surfaceIndex
)
Parameters:
  • surfaceIndex
  • Type: int
  • index of surface in brep's Surfaces list
Returns:
Type: BrepFace
Available since:
5.4

Description:

Add a new face to a brep. This creates a complete face with new vertices at the surface corners, new edges along the surface boundary, etc. The loop of the returned face has four trims that correspond to the south, east, north, and west side of the surface in that order. If you use this version of Add to add an exiting brep, then you are responsible for using a tool like JoinEdges() to hook the new face to its neighbors.

Syntax:
public BrepFace Add(
Surface surface
)
Parameters:
  • surface
  • Type: Surface
  • surface is copied
Returns:
Type: BrepFace
Available since:
5.4

Nothing found