Description:

Splits a single face into G1 pieces.

Syntax:
public bool SplitKinkyFace(
int faceIndex,
double kinkTolerance
)
Parameters:
  • faceIndex
  • Type: int
  • The index of the face to split.
  • kinkTolerance
  • Type: double
  • Tolerance (in radians) to use for crease detection.
Returns:
Type: bool
True on success, False on failure.
Remarks:
This function leaves deleted stuff in the brep. Call Brep.Compact() to remove deleted stuff.
Available since:
5.0

Nothing found