Description:
Add a planar trimming loop to a planar face
Syntax:
public BrepLoop AddPlanarFaceLoop(
int faceIndex,
BrepLoopType loopType,
IEnumerable<Curve> boundaryCurves
)
int faceIndex,
BrepLoopType loopType,
IEnumerable<Curve> boundaryCurves
)
Parameters:
- faceIndex
- Type: int
- index of planar face. The underlying surface must be a PlaneSurface
- loopType
- Type: BrepLoopType
- type of loop to add. If loopType is Unknown, then the loop direction is tested and the new loops type will be set to Outer or Inner. If the loopType is Outer, then the direction of the new loop is tested and flipped if it is clockwise. If the loopType is Inner, then the direction of the new loop is tested and flipped if it is counter-clockwise.
- boundaryCurves
- Type: IEnumerable<Curve>
- list of 3d curves that form a simple (no self intersections) closed curve. These curves define the 3d edge geometry and should be near the planar surface.
Returns:
Type: BrepLoop
new loop if successful
Available since:
5.4