Description:

Tests an ngon to see if the vertex and face references are valid and pass partial boundary validity checks.

Syntax:
public uint IsValid(
int index,
TextLog textLog
)
Parameters:
  • index
  • Type: int
  • The index of the ngon to test.
  • textLog
  • Type: TextLog
  • A text log for collecting information about problems.
Returns:
Type: uint
0 if the ngon is not valid, otherwise the number of boundary edges.
Remarks:
If the return value is > MeshNgon.BoundaryVertexCount, then the ngon has either inner boundaries or duplicate vertices.
Available since:
6.0

Description:

Tests an ngon to see if the vertex and face references are valid and pass partial boundary validity checks.

Syntax:
public uint IsValid(
int index
)
Parameters:
  • index
  • Type: int
  • The index of the ngon to test.
Returns:
Type: uint
0 if the ngon is not valid, otherwise the number of boundary edges.
Remarks:
If the return value is > MeshNgon.BoundaryVertexCount, then the ngon has either inner boundaries or duplicate vertices.
Available since:
6.0

Nothing found