Description:

Sets or adds a vertex to the Vertex List. If [index] is less than [Count], the existing vertex at [index] will be modified. If [index] equals [Count], a new vertex is appended to the end of the vertex list. If [index] is larger than [Count], the function will return false.

Syntax:
public bool SetColor(
int index,
Color color
)
Parameters:
  • index
  • Type: int
  • Index of vertex color to set. If index equals Count, then the color will be appended.
  • color
  • Type: Color
  • Color to set, Alpha channels will be ignored.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Sets or adds a vertex color to the color List. If [index] is less than [Count], the existing vertex at [index] will be modified. If [index] equals [Count], a new vertex is appended to the end of the vertex list. If [index] is larger than [Count], the function will return false.

Syntax:
public bool SetColor(
int index,
int red,
int green,
int blue
)
Parameters:
  • index
  • Type: int
  • Index of vertex color to set. If index equals Count, then the color will be appended.
  • red
  • Type: int
  • Red component of vertex color. Value must be in the 0~255 range.
  • green
  • Type: int
  • Green component of vertex color. Value must be in the 0~255 range.
  • blue
  • Type: int
  • Blue component of vertex color. Value must be in the 0~255 range.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Sets a color at the three or four vertex indices of a specified face.

Syntax:
public bool SetColor(
MeshFace face,
Color color
)
Parameters:
  • face
  • Type: MeshFace
  • A face to use to retrieve indices.
Returns:
Type: bool
True on success; False on error.
Available since:
5.0

Nothing found