Description:

Creates curves between two open or closed input curves. Uses the control points of the curves for finding tween curves. That means the first control point of first curve is matched to first control point of the second curve and so on. There is no matching of curves direction. Caller must match input curves direction before calling the function.

Syntax:
public static Curve[] CreateTweenCurves(
Curve curve0,
Curve curve1,
int numCurves,
double tolerance
)
Parameters:
  • curve0
  • Type: Curve
  • The first, or starting, curve.
  • curve1
  • Type: Curve
  • The second, or ending, curve.
  • numCurves
  • Type: int
  • Number of tween curves to create.
Returns:
Type: Curve[]
An array of tween curves. This array can be empty.
Available since:
6.0

Description:

Creates curves between two open or closed input curves. Uses the control points of the curves for finding tween curves. That means the first control point of first curve is matched to first control point of the second curve and so on. There is no matching of curves direction. Caller must match input curves direction before calling the function.

Syntax:
public static Curve[] CreateTweenCurves(
Curve curve0,
Curve curve1,
int numCurves
)
deprecated in 6.0
obsolete: Use version that takes tolerance as input
Parameters:
  • curve0
  • Type: Curve
  • The first, or starting, curve.
  • curve1
  • Type: Curve
  • The second, or ending, curve.
  • numCurves
  • Type: int
  • Number of tween curves to create.
Returns:
Type: Curve[]
An array of tween curves. This array can be empty.
Available since:
5.2

/
/
/
CreateTweenCurves

CreateTweenCurves method

Class:  Rhino.Geometry.Curve

Nothing found