Description:

For derived class implementers. This method is called with argument True when class user calls Dispose(), while with argument False when the Garbage Collector invokes the finalizer, or Finalize() method. You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true. Also, you must call the base virtual method within your overriding method.

Syntax:
protected override void Dispose(
bool disposing
)
protected
Parameters:
  • disposing
  • Type: bool
  • True if the call comes from the Dispose() method; False if it comes from the Garbage Collector finalizer.
Returns:
Type: void

Dispose method

Class:  Rhino.Geometry.Curve

Nothing found