Description:

Does a NURBS curve representation of this curve exist?

Syntax:
public int HasNurbsForm()
Returns:
Type: int
0 unable to create NURBS representation with desired accuracy. 1 success - NURBS parameterization matches the curve's to the desired accuracy 2 success - NURBS point locus matches the curve's and the domain of the NURBS curve is correct. However, This curve's parameterization and the NURBS curve parameterization may not match. This situation happens when getting NURBS representations of curves that have a transcendental parameterization like circles.
Available since:
5.0

HasNurbsForm method

Class:  Rhino.Geometry.Curve

Nothing found