Description:

Returns a curve's inflection points. An inflection point is a location on a curve at which the sign of the curvature (i.e., the concavity) changes. The curvature at these locations is always 0.

Syntax:
public Point3d[] InflectionPoints()
Returns:
Type: Point3d[]
An array of points if successful, None if not successful or on error.
Available since:
7.0

Description:

Returns a curve's inflection points. An inflection point is a location on a curve at which the sign of the curvature (i.e., the concavity) changes. The curvature at these locations is always 0.

Syntax:
public Point3d[] InflectionPoints(
out double curveParameters
)
Parameters:
  • curveParameters
  • Type: double
  • An array of curve parameters at the inflection points.
Returns:
Type: Point3d[]
An array of points if successful, None if not successful or on error.
Available since:
8.4

/
/
/
InflectionPoints

InflectionPoints method

Class:  Rhino.Geometry.Curve

Nothing found