Description:

Find parameter of the point on a curve that is locally closest to the testPoint. The search for a local close point starts at a seed parameter.

Syntax:
public bool LocalClosestPoint(
Point3d testPoint,
double seed,
out double t
)
Parameters:
  • testPoint
  • Type: Point3d
  • A point to test against.
  • seed
  • Type: double
  • The seed parameter.
  • t
  • Type: double
  • >Parameter of the curve that is closest to testPoint.
Returns:
Type: bool
True if the search is successful, False if the search fails.
Available since:
6.18

/
/
/
LocalClosestPoint

LocalClosestPoint method

Class:  Rhino.Geometry.Curve

Nothing found