Description:

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.

Syntax:
public bool NormalizedLengthParameter(
double s,
out double t,
double fractionalTolerance,
Interval subdomain
)
Parameters:
  • s
  • Type: double
  • Normalized arc length parameter. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
  • t
  • Type: double
  • Parameter such that the length of the curve from its start to t is arc_length.
  • fractionalTolerance
  • Type: double
  • Desired fractional precision. fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.
  • subdomain
  • Type: Interval
  • The calculation is performed on the specified sub-domain of the curve.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve.

Syntax:
public bool NormalizedLengthParameter(
double s,
out double t,
double fractionalTolerance
)
Parameters:
  • s
  • Type: double
  • Normalized arc length parameter. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
  • t
  • Type: double
  • Parameter such that the length of the curve from its start to t is arc_length.
  • fractionalTolerance
  • Type: double
  • Desired fractional precision. fabs(("exact" length from start to t) - arc_length)/arc_length <= fractionalTolerance.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve. A fractional tolerance of 1e-8 is used in this version of the function.

Syntax:
public bool NormalizedLengthParameter(
double s,
out double t,
Interval subdomain
)
Parameters:
  • s
  • Type: double
  • Normalized arc length parameter. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
  • t
  • Type: double
  • Parameter such that the length of the curve from its start to t is arc_length.
  • subdomain
  • Type: Interval
  • The calculation is performed on the specified sub-domain of the curve.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

Description:

Input the parameter of the point on the curve that is a prescribed arc length from the start of the curve. A fractional tolerance of 1e-8 is used in this version of the function.

Syntax:
public bool NormalizedLengthParameter(
double s,
out double t
)
Parameters:
  • s
  • Type: double
  • Normalized arc length parameter. E.g., 0 = start of curve, 1/2 = midpoint of curve, 1 = end of curve.
  • t
  • Type: double
  • Parameter such that the length of the curve from its start to t is arc_length.
Returns:
Type: bool
True on success, False on failure.
Available since:
5.0

/
/
/
NormalizedLengthParameter

NormalizedLengthParameter method

Class:  Rhino.Geometry.Curve

Nothing found