Description:

Finds a curve by offsetting an existing curve tangent to a surface. The caller is responsible for ensuring that the curve lies on the input surface.

Syntax:
public Curve OffsetTangentToSurface(
Surface surface,
double height
)
Parameters:
  • surface
  • Type: Surface
  • Surface from which tangents are calculated.
  • height
  • Type: double
  • Offset distance.
Returns:
Type: Curve
Curve offset tangent to the surface, if successful, None otherwise. The offset curve is interpolated through a small number of points so if the surface is irregular or complicated, the result will not be a very accurate offset.
Available since:
8.3

/
/
/
OffsetTangentToSurface

OffsetTangentToSurface method

Class:  Rhino.Geometry.Curve

Nothing found