Description:
Returns a geometrically equivalent PolyCurve. The PolyCurve has the following properties 1. All the PolyCurve segments are LineCurve, PolylineCurve, ArcCurve, or NurbsCurve. 2. The NURBS Curves segments do not have fully multiple interior knots. 3. Rational NURBS curves do not have constant weights. 4. Any segment for which IsLinear() or IsArc() is True is a Line, Polyline segment, or an Arc. 5. Adjacent co-linear or co-circular segments are combined. 6. Segments that meet with G1-continuity have there ends tuned up so that they meet with G1-continuity to within machine precision.
Syntax:
public Curve Simplify(
CurveSimplifyOptions options,
double distanceTolerance,
double angleToleranceRadians
)
CurveSimplifyOptions options,
double distanceTolerance,
double angleToleranceRadians
)
Parameters:
- options
- Type: CurveSimplifyOptions
- Simplification options.
- distanceTolerance
- Type: double
- A distance tolerance for the simplification.
- angleToleranceRadians
- Type: double
- An angle tolerance for the simplification.
Returns:
Type: Curve
New simplified curve on success, None on failure.
Available since:
5.0