Description:

Try to convert this curve into an Ellipse using a custom tolerance.

Syntax:
public bool TryGetEllipse(
out Ellipse ellipse,
double tolerance
)
Parameters:
  • ellipse
  • Type: Ellipse
  • On success, the Ellipse will be filled in.
  • tolerance
  • Type: double
  • Tolerance to use when checking.
Returns:
Type: bool
True if the curve could be converted into an Ellipse.
Available since:
5.0

Description:

Try to convert this curve into an Ellipse within RhinoMath.ZeroTolerance.

Syntax:
public bool TryGetEllipse(
out Ellipse ellipse
)
Parameters:
  • ellipse
  • Type: Ellipse
  • On success, the Ellipse will be filled in.
Returns:
Type: bool
True if the curve could be converted into an Ellipse.
Available since:
5.0

Description:

Try to convert this curve into an Ellipse using a custom tolerance.

Syntax:
public bool TryGetEllipse(
Plane plane,
out Ellipse ellipse,
double tolerance
)
Parameters:
  • plane
  • Type: Plane
  • Plane in which the comparison is performed.
  • ellipse
  • Type: Ellipse
  • On success, the Ellipse will be filled in.
  • tolerance
  • Type: double
  • Tolerance to use when checking.
Returns:
Type: bool
True if the curve could be converted into an Ellipse within the given plane.
Available since:
5.0

Description:

Try to convert this curve into an Ellipse within RhinoMath.ZeroTolerance.

Syntax:
public bool TryGetEllipse(
Plane plane,
out Ellipse ellipse
)
Parameters:
  • plane
  • Type: Plane
  • Plane in which the comparison is performed.
  • ellipse
  • Type: Ellipse
  • On success, the Ellipse will be filled in.
Returns:
Type: bool
True if the curve could be converted into an Ellipse within the given plane.
Available since:
5.0

/
/
/
TryGetEllipse

TryGetEllipse method

Class:  Rhino.Geometry.Curve

Nothing found