Description:

Bounding box solver. Gets the world axis aligned bounding box for the geometry.

Syntax:
public BoundingBox GetBoundingBox(
bool accurate
)
Parameters:
  • accurate
  • Type: bool
  • If true, a physically accurate bounding box will be computed. If not, a bounding box estimate will be computed. For some geometry types there is no difference between the estimate and the accurate bounding box. Estimated bounding boxes can be computed much (much) faster than accurate (or "tight") bounding boxes. Estimated bounding boxes are always similar to or larger than accurate bounding boxes.
Returns:
The bounding box of the geometry in world coordinates or BoundingBox.Empty if not bounding box could be found.
Available since:
5.0

Description:

Aligned Bounding box solver. Gets the plane aligned bounding box.

Syntax:
public BoundingBox GetBoundingBox(
Plane plane,
out Box worldBox
)
Parameters:
  • plane
  • Type: Plane
  • Orientation plane for BoundingBox.
  • worldBox
  • Type: Box
  • Aligned box in World coordinates.
Returns:
A BoundingBox in plane coordinates.
Available since:
5.0

Description:

Aligned Bounding box solver. Gets the plane aligned bounding box.

Syntax:
public BoundingBox GetBoundingBox(
Plane plane
)
Parameters:
  • plane
  • Type: Plane
  • Orientation plane for BoundingBox.
Returns:
A BoundingBox in plane coordinates.
Available since:
5.0

Description:

Aligned Bounding box solver. Gets the world axis aligned bounding box for the transformed geometry.

Syntax:
public virtual BoundingBox GetBoundingBox(
Transform xform
)
virtual
Parameters:
  • xform
  • Type: Transform
  • Transformation to apply to object prior to the BoundingBox computation. The geometry itself is not modified.
Returns:
The accurate bounding box of the transformed geometry in world coordinates or BoundingBox.Empty if not bounding box could be found.
Available since:
5.0

Nothing found