Description:

Transforms the geometry. If the input Transform has a SimilarityType of OrientationReversing, you may want to consider flipping the transformed geometry after calling this function when it makes sense. For example, you may want to call Flip() on a Brep after transforming it.

Syntax:
public bool Transform(
Transform xform
)
Parameters:
  • xform
  • Type: Transform
  • Transformation to apply to geometry.
Returns:
Type: bool
True if geometry successfully transformed.
Available since:
5.0

Transform method

Class:  Rhino.Geometry.GeometryBase

Nothing found