Description:

Collapses a multiple mesh faces, determined by face aspect ratio, based on criteria found in Stan Melax's polygon reduction, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf

Syntax:
public int CollapseFacesByByAspectRatio(
double aspectRatio
)
Parameters:
  • aspectRatio
  • Type: double
  • Faces with an aspect ratio less than aspectRatio are considered as candidates.
Returns:
Type: int
Number of faces that were collapsed in the process.
Remarks:
This number may differ from the initial number of faces that meet the input criteria because the aspect ratios of some initial faces may be altered as other faces are collapsed.
Available since:
6.0

/
/
/
CollapseFacesByByAspectRatio

CollapseFacesByByAspectRatio method

Class:  Rhino.Geometry.Mesh

Nothing found