Description:

Collapses multiple mesh faces, with greater/less than edge length, based on the principles found in Stan Melax's mesh reduction PDF, see http://pomax.nihongoresources.com/downloads/PolygonReduction.pdf

Syntax:
public int CollapseFacesByEdgeLength(
bool bGreaterThan,
double edgeLength
)
Parameters:
  • bGreaterThan
  • Type: bool
  • Determines whether edge with lengths greater than or less than edgeLength are collapsed.
  • edgeLength
  • Type: double
  • Length with which to compare to edge lengths.
Returns:
Type: int
Number of edges (faces) that were collapsed, -1 for general failure (like bad topology or index out of range) or -2 if all of the edges would be collapsed and the resulting mesh would be invalid.
Remarks:
This number may differ from the initial number of edges that meet the input criteria because the lengths of some initial edges may be altered as other edges are collapsed.
Available since:
6.0

/
/
/
CollapseFacesByEdgeLength

CollapseFacesByEdgeLength method

Class:  Rhino.Geometry.Mesh

Nothing found