Description:

Constructs a flow space morph.

Syntax:
public FlowSpaceMorph(
Curve curve0,
Curve curve1,
bool reverseCurve0,
bool reverseCurve1,
bool preventStretching
)
Parameters:
  • curve0
  • Type: Curve
  • Base curve.
  • curve1
  • Type: Curve
  • Target curve.
  • reverseCurve0
  • Type: bool
  • If true, then direction of curve0 is reversed.
  • reverseCurve1
  • Type: bool
  • If true, then direction of curve1 is reversed.
  • preventStretching
  • Type: bool
  • If true, the length of the objects along the curve directions are not changed. If false, objects are stretched or compressed in the curve direction so that the relationship to the target curve is the same as it is to the base curve.
Available since:
5.9

Description:

Constructs a flow space morph.

Syntax:
public FlowSpaceMorph(
Curve curve0,
Curve curve1,
bool preventStretching
)
Parameters:
  • curve0
  • Type: Curve
  • Base curve.
  • curve1
  • Type: Curve
  • Target curve.
  • preventStretching
  • Type: bool
Available since:
5.9

FlowSpaceMorph constructor

Class:  Rhino.Geometry.Morphs.FlowSpaceMorph

Nothing found