Description:

Constructs a maelstrom space morph.

Syntax:
public MaelstromSpaceMorph(
Plane plane,
double radius0,
double radius1,
double angle
)
Parameters:
  • plane
  • Type: Plane
  • Plane on which the base circle will lie. Origin of the plane will be the center point of the circle.
  • radius0
  • Type: double
  • First radius.
  • radius1
  • Type: double
  • Second radius.
  • angle
  • Type: double
  • Coil angle in radians.
Remarks:
If radius0 = radius1 > 0, then the morph is a rotation where the angle of rotation is proportional to the radius. If radius0 < radius1, then everything inside of the circle of radius radius0 if fixed, the rotation angle increases smoothly from 0 at radius0 to m_a at radius1, and everything outside of the circle of radius radius1 is rotated by angle. If radius0 > radius1, then everything outside of the circle of radius radius0 if fixed, the rotation angle increases smoothly from 0 at radius0 to m_a at radius1, and everything inside of the circle of radius radius1 is rotated by angle.
Available since:
5.9

MaelstromSpaceMorph constructor

Class:  Rhino.Geometry.Morphs.MaelstromSpaceMorph

Nothing found