Namespace: Rhino.GeometryPlane: references
Plane(double a, double b, double c, double d)
Plane(Plane other)
Plane(Point3d origin, Point3d xPoint, Point3d yPoint)
Plane(Point3d origin, Vector3d normal)
Plane(Point3d origin, Vector3d xDirection, Vector3d yDirection)
IsValid
Normal
Origin
OriginX
OriginY
OriginZ
Unset
WorldXY
WorldYZ
WorldZX
XAxis
YAxis
ZAxis
Clone()
ClosestParameter(Point3d testPoint, out double s, out double t)
ClosestPoint(Point3d testPoint)
CreateFromFrame(Point3d origin, Vector3d xDirection, Vector3d yDirection)
CreateFromNormal(Point3d origin, Vector3d normal)
CreateFromNormalYup(Point3d origin, Vector3d normal, Vector3d yDirection)
CreateFromPoints(Point3d origin, Point3d xPoint, Point3d yPoint)
DistanceTo(BoundingBox bbox, out double min, out double max)
DistanceTo(Point3d testPoint)
EpsilonEquals(Plane other, double epsilon)
Equals(object obj)
Equals(Plane plane)
ExtendThroughBox(BoundingBox box, out Interval s, out Interval t)
ExtendThroughBox(Box box, out Interval s, out Interval t)
FitPlaneToPoints(IEnumerable<Point3d> points, out Plane plane, out double maximumDeviation)
FitPlaneToPoints(IEnumerable<Point3d> points, out Plane plane)
Flip()
GetHashCode()
GetPlaneEquation()
IsCoplanar(Plane plane, double tolerance)
IsCoplanar(Plane plane)
PointAt(double u, double v, double w)
PointAt(double u, double v)
RemapToPlaneSpace(Point3d ptSample, out Point3d ptPlane)
Rotate(double angle, Vector3d axis, Point3d centerOfRotation)
Rotate(double angle, Vector3d axis)
Rotate(double sinAngle, double cosAngle, Vector3d axis, Point3d centerOfRotation)
Rotate(double sinAngle, double cosAngle, Vector3d axis)
ToString()
ToString(string format,IFormatProvider formatProvider)
Transform(Transform xform)
Translate(Vector3d delta)
UpdateEquation()
ValueAt(Point3d p)
!=
==